Summary

The BIGmack indicator LED can flash red. If you see it flash red 3 to 5 times and your message doesn’t play, this may indicate a battery problem.

Causes

  1. Low or Depleted Batteries: The batteries in your device may need to be replaced.
  2. Battery Type Issues: Rechargeable batteries or batteries labeled “Heavy Duty,” “Industrial Grade,” or “ProCell ” may cause the device to behave as if the batteries are low or dead. These battery types manage power differently from regular alkaline batteries and are not recommended for use with this product.

Solutions

  • Replace the batteries with new, regular alkaline batteries.
  • Make sure the replacement batteries are fresh and recently purchased. Batteries used in other devices or sitting unused for some time may not have enough power to operate your device properly.

By following these guidelines, you can help ensure your device works as expected and avoid issues with recording or playing messages.

Next Steps

Replace your battery and try to use it again if the problem persists, contact ableCARE for further assistance.

Please visit the BIGmack Support Hub for additional support resources. If you have any additional questions, please contact the ableCARE Product Success Team for further assistance.

BIGmack

Getting Started With BIGmack Speech Device The colored switch cap comes off my BIGmack while using it. Is there a way to secure it so it doesn’t come off as easily? Why does the LED flash Red 3-5 times and not play my message on my BIGmack? Why does the LED flash yellow one time and not play my message on my BIGmack?

Additional topics for Speech Devices

Additional topics for Assistive Technology

Browse Support by Product or Category

Still need more help?

Learn more