Summary

If you are unable to record a new message on the QuickTalker FT, it may be due to the device needing new batteries, being locked, or having a full memory. You can resolve these issues by following the steps outlined below.

Causes

  • The device may need new batteries.
  • The device may be locked.
  • The memory may be full or corrupted, indicated by the record indicator lamp lighting up orange.

Solutions

Please reference the below image when following the troubleshooting steps.

QuickTalker FT product diagram for troubleshooting can't record a new message on a QuickTalker FT

Replace the Batteries

There are 2 types of battery issues that can arise with the QuickTalker FT that may impact your ability to record a new message:

  1. The batteries you have in your QuickTalker FT may be low or depleted.
  2. The batteries you are using are labeled “Heavy Duty,” “Industrial Grade,” or “ProCell.” These types of batteries handle power differently than regular alkaline batteries, and when used in our devices, they behave similarly to low or dead batteries.

If you are experiencing difficulties recording, we recommend first replacing the existing batteries with brand new, recently purchased batteries. Always using regular, alkaline batteries to avoid any issues with recording or playing messages. Batteries that have been  used for other devices or those that have been sitting a while may not have the power to operate the switch correctly.

Disable the Lock Feature

The QuickTalker FT devices have a lock feature that prevents changes being made to the device, including recording new messages. To lock or unlock the QuickTalker FT:

  1. Press and hold the Record and Level buttons simultaneously for 5 seconds.
  2. When the device has been unlocked, all lights will flash twice and then turn off.

Clear the Memory

The QuickTalker FT devices have different amounts memory available:

  • QuickTalker FT 7 – 6 minutes of total record time
  • QuickTalker FT 12 – 12 minutes of total record time
  • QuickTalker FT 23 – 20 minutes of total record time

If the maximum amount of record time is reached, the memory will be full and you will not be able to record additional messages. To clear the device’s memory:

  1. Press and hold the Record button for 20-30 seconds.
  2. When the memory has been fully erased, you will hear two short beeps indicating the process is complete.

Next Steps

Please visit the QuickTalker FT Support Hub for additional support resources. If the recording problem persists or if you have any additional questions, please contact the ableCARE Product Success Team for further assistance.

QuickTalker FT 7, 12, and 23

How To Fix Glitching Audio When Recording on My QuickTalker FT Getting Started With QuickTalker FT 7, 12, and 23 Speech Devices Why does the QuickTalker FT LED alternate flashing between red and yellow two times and not play my message? Why can’t I record a new message on a QuickTalker FT?

Additional topics for Speech Devices

Additional topics for Assistive Technology

Browse Support by Product or Category

Still need more help?

Learn more